Установка Zabbix-agent 2.2 в Debian Squezee

В официальных репозитариях Debian Squezee есть zabbix версии 1.8 Я же хотел установить zabbix-agent хотя бы версии 2.0 Но оказалось что для Debian Squezee в репах Zabbix-а есть агент версии 2.2 Его я и буду ставить! Для начала качаем файлик с репозитарием:

black@deb5:~$ wget -c http://repo.zabbix.com/zabbix/2.2/debian/pool/main/z/zabbix-release/zabbix-release_2.2-1+squeeze_all.deb

И установим его:

black@deb5:~$ sudo dpkg -i zabbix-release_2.2-1+squeeze_all.deb
Selecting previously deselected package zabbix-release.
(Reading database ... 54804 files and directories currently installed.)
Unpacking zabbix-release (from zabbix-release_2.2-1+squeeze_all.deb) ...
Setting up zabbix-release (2.2-1+squeeze) ...
black@deb5:~$

Поехали дальше …
Обновим информацию о пакетах:

black@deb5:~$ sudo apt-get update
......
Get:1 http://repo.zabbix.com squeeze Release.gpg [198 B]
Ign http://repo.zabbix.com/zabbix/2.2/debian/ squeeze/main Translation-en
Ign http://repo.zabbix.com/zabbix/2.2/debian/ squeeze/main Translation-en_US
Get:2 http://repo.zabbix.com squeeze Release [6,560 B]
Ign http://repo.zabbix.com squeeze/main Sources
Get:3 http://repo.zabbix.com squeeze/main amd64 Packages [2,747 B]                      
......
Fetched 10.6 kB in 1s (6,990 B/s)
Reading package lists... Done
black@deb5:~$

Теперь пробуем установить zabbix-agent

black@deb5:~$ sudo apt-get install zabbix-agent
Reading package lists... Done
Building dependency tree      
Reading state information... Done
The following package was automatically installed and is no longer required:
  libopenipmi0
Use 'apt-get autoremove' to remove them.
The following NEW packages will be installed:
  zabbix-agent
0 upgraded, 1 newly installed, 0 to remove and 16 not upgraded.
Need to get 401 kB of archives.
After this operation, 823 kB of additional disk space will be used.
Get:1 http://repo.zabbix.com/zabbix/2.2/debian/ squeeze/main zabbix-agent amd64 1:2.2.7-1+squeeze [401 kB]
Fetched 401 kB in 0s (1,024 kB/s)    
Preconfiguring packages ...
Selecting previously deselected package zabbix-agent.
(Reading database ... 54810 files and directories currently installed.)
Unpacking zabbix-agent (from .../zabbix-agent_1%3a2.2.7-1+squeeze_amd64.deb) ...
Processing triggers for man-db ...
Setting up zabbix-agent (1:2.2.7-1+squeeze) ...

Creating config file /etc/zabbix/zabbix_agentd.conf with new version
Starting Zabbix agent: zabbix_agentd.
black@deb5:~$

Отлично! Zabbix-agent версии 2.2 установлен и готов к настройке.

Хай щастить!

  1. Комментов пока нет

  1. Трэкбэков пока нет.

Why ask?