Пара проблем с XFCE 4.8 на Debian Wheezy

Возникла тут проблемка с установкой Debian Squeeze на один ноут. Если точнее, то проблема была с сетевой карточкой на ноуте

02:00.0 Ethernet controller: Atheros Communications AR8152 v2.0 Fast Ethernet (rev c1)

которая ну никак не хочет нормально работать со стабильным дебовским ядром 2.6.32. Соединение то отваливается, то приваливается …. и вообще что-то странное происходит с работой сети через эту карточку. Я даже не стал вникать особо в суть проблемы, так как почти сразу нагуглил что данная сетевушка со старенькими ядрами вот так вот и работает. И мол панацея — сборка + установка более нового ядра. Таким гемором мне точно лень заниматься, вот и решил поставить Debian testing — тут и ядро подходящее да и софт посвежее. Попути возникли пару проблемок — но вполне решабильные.
Проблема с монтированием флэшек в XFCE 4.8 (Debian Wheezy)
С роздачи не заработала ни под каким предлогом 🙁 Перелопатил интернет вдоль и впоперек, и только под конец рабочего дня нашел дельный совет по этому поводу (спасибо форуму Arch Linux)
Решение предложили весьма нетривиальное, сам врятли бы додумался 🙂
Лезем в рутовую консоль и создаем вот такой файлик:

root@ws:~# vim /etc/polkit-1/localauthority/50-local.d/org.freedesktop.udisks.pkla

с вот таким содержимым:

[Local Users]
Identity=unix-group:storage
Action=org.freedesktop.udisks.*
ResultAny=yes
ResultInactive=no
ResultActive=yes

И сразу же можем тестить флешку 🙂 У меня заработало, чего и Вам желаю 😉
Проблема с Выключением/перезагрузкой из под пользователя в XFCE 4.8
Тоже нагуглил вот такое решение:
в рутовой консоли создаем файлик:

root@ws:~# vim /etc/polkit-1/localauthority/50-local.d/org.freedesktop.consolekit.pkla

с таким содержимым:

[Local restart]
Identity=unix-user:myuser
Identity=unix-group:users
Action=org.freedesktop.consolekit.system.restart
ResultAny=yes
ResultInactive=no
ResultActive=yes

[Local shutdown]
Identity=unix-user:myuser
Identity=unix-group:users
Action=org.freedesktop.consolekit.system.stop
ResultAny=yes
ResultInactive=no
ResultActive=yes

После этого из под пользователя все прекрасно работает
Ну пака все 🙂 Будем рыть дальше ….. в поисках юзабилити 😉

    • poul
    • Декабрь 11th, 2012 10:38пп

    Спасибо, помогло!

    • poul
    • Декабрь 12th, 2012 12:43дп

    P.S. Ещё добавлю, что myuser должен быть в группе users.

  1. Трэкбэков пока нет.

Why ask?